21.10.2010

Установка принтера Canon iP1500 в Ubuntu 10.10


Мой старый принтер Canon iP1500 под 10-ой как всегда не работал, пришлось поковырятся, но в итоге он таки заработал.

Что бы заработал Canon iP1500 в Ubuntu 10.10:
качаем и ставим пересобранные пакеты для Ubuntu кроме pstocanonbj (он хочет cupsys и конфликтует с имеющейся версией cups, как побороть этот выбрык читайте ниже)
sudo dpkg -i *.deb
- bjfilter-2.5_1-1_i386
- libcnbj-2.5_0-1_i386
- pstocanonbj_3.3-1_i386
последний pstocanonbj потребует по зависимости libcupsys2 - он есть на launchpad
- libcupsys2_1.3.9-17ubuntu1_all качаем, ставим.

или качаем все пакеты одним архивом

Распаковываем пакет pstocanonbj
dpkg --extract pstocanonbj_3.3-1_i386.deb /home/mk/tmp/

копируем файл pstocanonbj из той папки в которую распаковано дерево deb пакета в /usr/lib/cups меняем владельца и группу на рута sudo chown root:root pstocanonbj
копируем файл из той папки в которую распаковано дерево deb пакета в canonpixmaip1500.ppd
в/usr/share/ppd меняем владельца и группу на рута sudo chown root:root canonpixmaip1500.ppd

Перезапускаем сервис печати (или перезагружаемся):
sudo /etc/init.d/cups restart

После установки в меню создаем новый принтер
через веб-интерфейс Cups http://localhost:631/

Документы печатает без проблем с разрешением 600 dpi, в 10.10 появилось разрешение 1200, но принтер его не поддерживает и так же появилвсь опция качества печати "High".